Ticket #32 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

listing of items seems incorrect in debugger

Reported by: kowey Owned by: kowey
Priority: major Milestone:
Component: gui Version:
Keywords: Cc:

Description

I could have sworn I kept seeing something like this happen.

See geni -m dist/build/grammar/valuation-sem.geni -l dist/build/lexicon/lemmas.glex -s suite/verbs --testcase=t110 and skip 140 steps

Change History

Changed 5 years ago by kowey

You can tell that it's really nonsense, eg with RESULTS coming before AGENDA

Changed 5 years ago by kowey

Awesome: I can reproduce this with just the ej example and skipping one step at a time. I know that the internal GUI state is correct. Why are the widgets just not updating?

Changed 5 years ago by kowey

  • owner changed from somebody to kowey
  • status changed from new to assigned

Bleah! Well, I know how to make the symptoms go away, but I still don't ultimately know what the causes are. It's got something to do with setting selection on the list box (which causes the tail of my list to be appended to the front of it), but I can't reproduce it with a minimal demonstrator.

All I know is that not setting the selection works around the problem...

Changed 5 years ago by kowey

Fixed with:

  • Fix #32 (weird GUI bug with debugger).

Yeah! There was something I was doing which was buggy. It really ought to be boiled down into a wxHaskell test case though because the outcome is really bizzare.

Changed 5 years ago by kowey

  • status changed from assigned to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.