Ticket #39 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

geni accepts malformed rootfeat

Reported by: kowey Owned by:
Priority: major Milestone: GenI 0.22
Component: core Version:
Keywords: Cc:

Description

The square brackets should either be optional, or mandatory but enforced. Right now they are silently accepted and ignored.

Change History

Changed 3 years ago by kowey

My writeup of this problem was not very clear.

The problem is that if you plug in "cat:np" as a root feature instead of "[cat:np]", you get []. GenI should either explicitly reject it or just accept it sans square brackets as part of root feature input

Changed 3 years ago by kowey

  • status changed from new to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.