Ticket #21 (closed defect: wontfix)

Opened 2 years ago

Last modified 18 months ago

TS does not compile under Windows 7

Reported by: MikolajKonarski Owned by:
Priority: major Component: ThreadScope
Version: Keywords:
Cc:

Description

Compiler complains that widgetSetCanFocus is out of scope.
Compiles OK with the occurence of widgetSetCanFocus removed.

Versions: gtk2hs is 0.12.2, TS is 0.2.1 and GTK is 2.24.8.

The problem may be due to conditional compilation in gtk2hs,
which for that particular GTK version may switch off the widgetSetCanFocus. Not verified in the code.

Change History

  Changed 2 years ago by MikolajKonarski

Haskell Platform is 2011.4.0.0. See the full report by Kirill Kolodyazhniy on parallel-haskell.

follow-up: ↓ 5   Changed 2 years ago by duncan

Odd

#if GTK_CHECK_VERSION(2,18,0)
  widgetGetCanFocus,
  widgetSetCanFocus,
  widgetGetAllocation,
#endif

But I've also seen other reports of this from windows users. We should confirm what GTK version gtk2hs was really built against.

  Changed 2 years ago by MikolajKonarski

  Changed 2 years ago by MikolajKonarski

False alarm. The bug above was caused by manually faked pkg-config.

in reply to: ↑ 2   Changed 2 years ago by bartoszw

Replying to duncan:

Odd

{{{
#if GTK_CHECK_VERSION(2,18,0)
widgetGetCanFocus,
widgetSetCanFocus,
widgetGetAllocation,
#endif
}}}

But I've also seen other reports of this from windows users. We should confirm what GTK version gtk2hs was really built against.

I've got problem with having widgetGetCanFocus and widgetSetCanFocus available with GTK version 2.18. I've got version 2.16 which contains already CAN_FOCUS and migration gtk2hs from 0.11.1 to 0.12.2 caused some compiling problems. I've solved it temporary for myself by moving these 2 functions under #if GTK_CHECK_VERSION(2,16,0).
Is there any good reason for having them only from version 2.18?
If not, would it be possible to fix it? I can contribute here if this is an issue.
I'm on Linux Mandriva 2009 (relatively old therefore GTK is old too).

  Changed 18 months ago by duncan

  • status changed from new to closed
  • resolution set to wontfix

So I don't think this is really a problem we need to solve. It's true that if we fixed the gtk binding, we could make it work ok for users of Gtk+2.16, but Gtk+ 2.16 is really ancient these days, even for windows. The latest Gtk+ Win32 bundle on the Gtk+ download page is 2.24.

My suggestion is we just tell users to use a more recent gtk version.

Note: See TracTickets for help on using tickets.