Ticket #43 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

Building fails.

Reported by: Grigory Owned by: tmcdonell
Priority: major Milestone:
Component: CUDA backend Version: 0.8.1.0
Keywords: Cc: sargrigory@…

Description

I'm trying to install accelerate from cabal.

I have CUDA 3.2 installed on Ubuntu 11.04, samples from SDK compile and run fine. But when I'm trying to install accelerate I have an error:

checking cuda.h usability... yes
checking cuda.h presence... yes
checking for cuda.h... yes
checking cuda_runtime_api.h usability... yes
checking cuda_runtime_api.h presence... yes
checking for cuda_runtime_api.h... yes
checking for library containing cuDriverGetVersion... -lcuda
checking for library containing cudaRuntimeGetVersion... -lcudart
configure: creating ./config.status
config.status: creating cuda.buildinfo
Preprocessing library cuda-0.2.2...
c2hs: Errors during expansion of binding hooks:

./Foreign/CUDA/Driver/Context.chs:76: (column 15) [ERROR]  >>> Unknown identifier!
  Cannot find a definition for `cuCtxCreate' in the header file.

cabal: Error: some packages failed to install:
accelerate-0.8.1.0 depends on cuda-0.2.2 which failed to install.
cuda-0.2.2 failed during the building phase. The exception was:
ExitFailure 1

I know, it's actually cuda-0.2.2 package, but maybe someone will help here?

0.3.2 can be installed, but accelerate requires < 3.

Change History

Changed 4 years ago by Grigory

  • status changed from new to closed
  • resolution set to duplicate
Note: See TracTickets for help on using tickets.