Ticket #2 (new enhancement)

Opened 4 years ago

Last modified 4 years ago

seq and pseq unsafety and ambiguities

Reported by: jmcarthur Owned by: somebody
Priority: major Milestone:
Component: component1 Version:
Keywords: Cc:

Description

base's seq and pseq functions break parametricity, which, among other things, is required for some optimizations like deforestation to work. Therefore, I propose that they be considered unsafe functions and that we adopt the unsafe naming conventions for them. Furthermore, since seq doesn't actually guarantee in what order its arguments are evaluated, its name should not resemble "sequence." Perhaps it could be renamed to something like unsafeForce. pseq, then, would be renamed to unsafeSeq.

Change History

Changed 4 years ago by anonymous

  • type changed from defect to enhancement
Note: See TracTickets for help on using tickets.