Ticket #191 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

ddc doesn't find modules in current directory

Reported by: erikd Owned by: erikd
Priority: blocker Milestone: 0.1.3
Component: Compilation Driver Version: 0.1.2
Keywords: Cc:

Description

Have two module in the current directory; Main.ds and Test.ds

/path/to/ddc -basedir /path/to/basedir --make Main.ds -o program

fails with:

ddc error: can't find source for module 'Test'

imported by: /home/erikd/Hack/Darcs/DDC/ddc-head/test/10-Driver/LocalMake/Main.ds

This is caused by having an empty string in importDirs which then triggers a bug in GHC's System.Directory.canonicalize :

http://hackage.haskell.org/trac/ghc/ticket/4480

Change History

Changed 4 years ago by erikd

  • status changed from new to closed
  • resolution set to fixed

Fix in:

Sun Nov  7 15:34:18 EST 2010  Erik de Castro Lopo <erikd@mega-nerd.com>
  * Move test/Broken-skip/T191-LocalMake/ to test/10-Driver.

Sun Nov  7 15:31:23 EST 2010  Erik de Castro Lopo <erikd@mega-nerd.com>
  * Fix #191: ddc doesn't find modules in current directory.
Note: See TracTickets for help on using tickets.