Ticket #2 (closed enhancement: fixed)

Opened 3 years ago

Last modified 3 years ago

Try doing bounds transformations with inverse transpose

Reported by: byorgey Owned by: byorgey
Priority: minor Milestone:
Component: core Version:
Keywords: bounds, transformations Cc:

Description

The current scheme for applying transformations to bounding regions works, but is sort of complicated. According to this page, however, it seems like it may be possible to do the proper transformation more simply, in terms of inverse transpose transformations. We could carry around the inverse transpose along with transformations (just as we currently carry around the inverse). We ought to experiment at some point to see if this method will work, and whether it leads to less/simpler code and/or faster execution.

Change History

Changed 3 years ago by byorgey

  • owner byorgey deleted

Changed 3 years ago by byorgey

  • owner set to byorgey

I think I have this working (I haven't pushed any patches yet though). However, it's uncovered another bug regarding translations (summary: translating a *vector* (as opposed to a point) ought to be a no-op!) which I hope is the cause of #7. Hopefully I'll have something pushed soon.

Changed 3 years ago by byorgey

  • status changed from new to closed
  • resolution set to fixed

This is now pushed. I seem to have introduced other bugs in the process, but they can be fixed. =)

Note: See TracTickets for help on using tickets.