Ticket #1100 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

Build fails with gtk2-2.4.14 - patch included

Reported by: guest Owned by: somebody
Priority: normal Milestone:
Component: general (Gtk+, Glib) Version: 0.9.12
Keywords: Cc:

Description

I have a seriously old version of gtk2: 2.4.14 (from Fedora Core 2 - yes I know I should upgrade!). Building gtk2hs-0.9.12.1 fails like this:

/usr/local/bin/ghc +RTS -RTS -split-objs -c gtk/Graphics/UI/Gtk/ModelView/CellLayout.hs -o gtk/Graphics/UI/Gtk/ModelView/CellLayout.o -O -fffi -igtk: -package-conf package.conf.inplace -hide-all-packages -ignore-package gtk -package base -package mtl-1.0 -package glib-0.9.12.1 -package-name gtk-0.9.12.1 '-#include<gtk/gtk.h>' -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/gtk-2.0
-I/usr/lib/gtk-2.0/include -I/usr/X11R6/include -I/usr/include/freetype2 -I/usr/include/atk-1.0
 
gtk/Graphics/UI/Gtk/ModelView/CellLayout.chs.pp:78:25:
    Not in scope: type constructor or class `CellView'
 
gtk/Graphics/UI/Gtk/ModelView/CellLayout.chs.pp:82:25:
    Not in scope: type constructor or class `IconView'

Problem seems to be CellView? and IconView? are only built if you have gtk2-2.6.0, but the #if in CellLayout?.chs.pp only checks for gtk2-2.4.0.

The (trivial) patch attached fixes the problem for me.

Tim Goodwin (info@…)

Attachments

patch (469 bytes) - added by guest 10 years ago.
trivial patch

Change History

Changed 10 years ago by guest

trivial patch

Changed 10 years ago by guest

I've applied your patch, thanks!

Changed 10 years ago by axel

  • status changed from new to closed
  • resolution set to fixed

Changed 10 years ago by guest

Patch confirmed on RHEL4 with gtk2-2.4.13.

Note: See TracTickets for help on using tickets.