Ticket #1104 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

CULong -> CUInt needed in Gstreamer chs modules to build on 32-bit system.

Reported by: guest Owned by: somebody
Priority: normal Milestone:
Component: general (Gtk+, Glib) Version: 0.9.12
Keywords: Cc: harold.wadleigh@…

Description

Only CULong is declared in the files, but c2hs seems to generate references to CUInt.

I'm having the problem on 32-bit Ubuntu. I don't recall hitting any glitches when I compiled it on my 64-bit Ubuntu machine.

My fix: I just added CUInt to the imports. Diff attached.

Attachments

cuint.diff (4.1 kB) - added by guest 6 years ago.
Patch file to add delcaration of CUInt to chs modules under GStreamer.

Change History

Changed 6 years ago by guest

Patch file to add delcaration of CUInt to chs modules under GStreamer.

Changed 6 years ago by axel

I've already patched the two template files, is that not enough? (see #1103 )

Changed 6 years ago by pgavin@…

The template files are sufficient. The .chs files are generated, and aren't even in darcs (and it seems that cuint.diff isn't a proper darcs patch anyhow).

Changed 6 years ago by axel

  • status changed from new to closed
  • resolution set to duplicate

duplicate of #1103

Note: See TracTickets for help on using tickets.