Ticket #1128 (closed task: fixed)

Opened 6 years ago

Last modified 5 years ago

Support cabal install

Reported by: guest Owned by: duncan
Priority: blocker Milestone: 1.0
Component: general (Gtk+, Glib) Version: 0.9.12
Keywords: cabal, build, install Cc:

Description

soegtk-9.12.2 fails to build. I get the following error message:

~/tmp/soegtk-0.9.12.2: cabal install
Resolving dependencies...
Configuring soegtk-0.9.12.2...
Preprocessing library soegtk-0.9.12.2...
Building soegtk-0.9.12.2...

Graphics/SOE/Gtk.hs:94:17:
    Could not find module `System.Time':
      it is a member of package old-time-1.0.0.0, which is hidden
cabal: Error: some packages failed to install:
soegtk-0.9.12.2 failed during the building phase. The exception was:
exit: ExitFailure 1

Change History

Changed 6 years ago by anonymous

  • summary changed from soegtk Fails to build to q

Ah, I see where the problem lies. This error does not occur when I build the package with ghc --make. Apparently, cabal will hide all modules not explicitly required by the .cabal file. So, to fix this problem, I simply added "old-time" to the requirements.

Maybe this should be added upstream?

Changed 6 years ago by pgavin

  • status changed from new to closed
  • resolution set to duplicate

We don't support cabal (but plan to in the future). Marking as duplicate.

Changed 6 years ago by guest

  • status changed from closed to reopened
  • type changed from defect to task
  • component changed from SOE package to general (Gtk+, Glib)
  • summary changed from q to Support cabal install
  • milestone set to 1.0
  • keywords cabal, install added; fail, install, time removed
  • resolution duplicate deleted

Duplicate of what? Let's make this bug the cabal install task.

Changed 5 years ago by axel

  • status changed from reopened to closed
  • resolution set to fixed

Now all things are cabal and this is no longer an issue since cabal handles this.

Note: See TracTickets for help on using tickets.