Ticket #1132 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

0.9.13 fails to build on PPC/Linux/ghc6.8.3

Reported by: guest Owned by: somebody
Priority: normal Milestone: 0.9.13
Component: general (Gtk+, Glib) Version: 0.9.12
Keywords: Cc: bos@…

Description

Here's a build log: http://koji.fedoraproject.org/koji/getfile?taskID=714114&name=build.log

Scroll down to near the end and you'll see this:

/usr/bin/ghc-6.8.3 +RTS -RTS -c tools/c2hs/toplevel/C2HSConfig.hs -o tools/c2hs/toplevel/C2HSConfig.o -O -fffi -fvia-C '-#include<c2hs_config.h>' -itools/c2hs/base/admin:tools/c2hs/base/errors:tools/c2hs/base/general:tools/c2hs/base/state:tools/c2hs/base/syms:tools/c2hs/base/syntax:tools/c2hs/c:tools/c2hs/chs:tools/c2hs/gen:tools/c2hs/state:tools/c2hs/toplevel -package-conf package.conf.inplace -hide-all-packages -package base -package haskell98 -package pretty -package containers -package array
P
rologue junk?: 	.type	s1d1_ret, @function
s1d1_ret:
 # 106 "/tmp/ghc24442_0/ghc24442_0.hc" 1
make[2]: *** [tools/c2hs/toplevel/C2HSConfig.o] Error 255

This looks like bad compiler output, as opposed to a problem with gtk2hs itself, but I wanted another pair or three of eyeballs to be sure.

The build system I'm using is Fedora's batch system, so it's nearly impossible for me to give a more useful reproduction :-(

Change History

Changed 6 years ago by guest

Removing -fvia-C from Makefile.am, as suggested in IRC by Duncan, fixes the problem.

Changed 6 years ago by axel

  • status changed from new to closed
  • resolution set to fixed

Changed 6 years ago by Alvaro

A failure will not appear until a unit has passed final inspection. come comprare viagra online generic fioricet acquisti cialis italia order cheap tramadol online

Changed 6 years ago by Alvaro

I judge a religion as being good or bad based on whether its adherents become better people as a result of practicing it. - Joe Mullally, computer salesman 10 viagra 10 cialis fioricet rx ordina cialis tramadol usa

Note: See TracTickets for help on using tickets.