Ticket #1164 (closed defect: wontfix)

Opened 6 years ago

Last modified 4 years ago

System.Gnome.GConf.gconfSet appears to reverse list

Reported by: guest Owned by: pgavin
Priority: normal Milestone: 0.12.0
Component: GConf bindings Version: 0.11.0
Keywords: gconf gconfset reverse gslist glist Cc: staffan.bjornesjo@…, gtk2hs-bug-tracker@…

Description

System.Gnome.GConf.gconfSet reverses the list. see attached example.

Attachments

gc.hs (1.0 kB) - added by guest 6 years ago.
example program that shows the error
reversed-toGSList.dpatch (5.9 kB) - added by guest 6 years ago.
fix

Change History

Changed 6 years ago by guest

example program that shows the error

Changed 6 years ago by pgavin

  • owner changed from duncan to pgavin

Changed 6 years ago by pgavin

  • milestone set to 0.10.2

Changed 6 years ago by guest

fix

Changed 5 years ago by axel

  • status changed from new to closed
  • resolution set to fixed

Patch applied!

Changed 4 years ago by guest

  • status changed from closed to reopened
  • cc gtk2hs-bug-tracker@… added
  • version changed from 0.9.13 to 0.11.0
  • milestone changed from 0.10.2 to 0.12.0
  • keywords gslist glist added
  • resolution fixed deleted

Still present in gconf-0.11.0. If lists are not supposed to get reversed when creating a GList or GSList, then the bug is in the System.Glib.GList, otherwise it is in System.Gnome.GConf.GConfValue.

Changed 4 years ago by axel

  • status changed from reopened to closed
  • resolution set to wontfix

We cannot reproduce that the list is reversed when storing them into GConf. I'll close this ticket.

Note: See TracTickets for help on using tickets.