Ticket #1165 (closed defect: wontfix)

Opened 5 years ago

Last modified 4 years ago

gtk2hs does not install on haskell platform under windows

Reported by: guest Owned by: somebody
Priority: normal Milestone: 0.10.1
Component: general (Gtk+, Glib) Version: 0.10.1
Keywords: gtk2hs haskell platform Cc: joaopizani@…, mail@…

Description

I just tried the new haskell platform installer under Windows XP. When subsequently trying to install gtk2hs 0.10.0, the installer complains that ghc 6.10.1 in required (the platform is 6.10.2) and that i need to fix the searchpath myself (any help on how to do this?). Cabal cannot install cairo/gtk dependent pkgs.

Attachments

gtk2hs.log (2.7 kB) - added by guest 5 years ago.
error log of installation

Change History

  Changed 5 years ago by guest

  • version changed from 0.10.0 to 0.10.1
  • milestone changed from 0.10.0 to 0.10.1

As far as I understood, the version of Ghc should always match the one the Gtk2Hs installer requires. However, I have the same problem with Gtk2Hs 0.10.1 (which requires Ghc 6.10.3) and a fresh Haskell Platform 2009.2.0.1 that features Ghc 6.10.3. I deleted all of my previous installations. I checked that environment variables were ok and that the compiler used by the installation process was the correct one. I used the win32 installer under Windows XP. Installation actually performed ok; I just have to "fix the DLL search path problem", and I don't know how to do this me neither. The PATH environment variable already points to the bin directory.

  Changed 5 years ago by guest

  • cc joaopizani@… added
  • keywords gtk2hs haskell platform added

I am having exactly the same problem here. I have a freshly installed WinXP SP2, in it I installed the most recent Haskell Platform (2009.2.0.1) with no problems.

Then in the installation of Gtk2Hs a message was shown saying I had to fix the search path myself. How can I do that?

Just thinking if it's not the time for Gtk2Hs to become cabalized...

  Changed 5 years ago by guest

The problem has to do with whitespace in the path to ghc. I had the same problem with Haskell Platform, but then reinstalled it to a path without whitespaces (instead of c:\Program Files\Haskell Platform\version it became c:\progr\HaskellPlatform?\version) and then the gtk2hs installation worked as it should.

Changed 5 years ago by guest

error log of installation

  Changed 5 years ago by guest

I've just run into this problem as well. The installer talks about a "broken install", which is indeed caused by the spaces in the install path. When removing them, the gtk2hs installer changes its error message to "Wrong version of GHC", which is correct since I'm using the newest Haskell Platform (downloading an older release now...)

Any clue what causes this? Considering that the haskell platform installer installs into Program Files by default, not allowing spaces isn't really working...

follow-ups: ↓ 6 ↓ 8   Changed 4 years ago by guest

I believe the problem is in the ExecOutput function, where the line:

    if Exec(ExpandConstant('{cmd}'), '/C ' + Filename + ' ' + Params + ' > ' + TmpFile,

should add quotes around Filename:

    if Exec(ExpandConstant('{cmd}'), '/C "' + Filename + '" ' + Params + ' > ' + TmpFile,

in reply to: ↑ 5   Changed 4 years ago by guest

Is the solution from guest really the only problem with using the gtk2hs installer with the current haskell platform? Any change to see a release that works with 6.10.4 soon? --Joachim

  Changed 4 years ago by guest

  • cc mail@… added

I can add that the installer provided by Duncan at http://www.mail-archive.com/gtk2hs-devel@lists.sourceforge.net/msg00340.html works fine with a ghc that has spaces in the path.

in reply to: ↑ 5   Changed 4 years ago by duncan

Replying to guest:

I believe the problem is in the ExecOutput function, where the line: {{{ if Exec(ExpandConstant?('{cmd}'), '/C ' + Filename + ' ' + Params + ' > ' + TmpFile?, }}} should add quotes around Filename: {{{ if Exec(ExpandConstant?('{cmd}'), '/C "' + Filename + '" ' + Params + ' > ' + TmpFile?, }}}

I believe this is the correct fix (but I've not done a full end-to-end test).

Also, I don't think my installer does work with spaces. It does not contain the above fix.

  Changed 4 years ago by axel

  • status changed from new to closed
  • resolution set to wontfix

While 0.11.0 doesn't have a Windows installer, I hope that installing from sources is easy enough that a separate installer is not necessary. If people feel strongly about this and want an installer, we can reopen this ticket.

Note: See TracTickets for help on using tickets.