Ticket #1189 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

gtk package fails to build on debian stable

Reported by: guest Owned by: somebody
Priority: normal Milestone: 0.11.0
Component: general (Gtk+, Glib) Version: 0.11.0
Keywords: Cc: jurgen.doser@…

Description

cabal install gtk installs a couple of packages fine (glib, gio, cairo, pango), then fails with the following error message:

Configuring gtk-0.11.0...
Preprocessing library gtk-0.11.0...
gtk2hsC2hs: Errors during expansion of binding hooks:

./Graphics/UI/Gtk/Builder.chs:165: (column 18) [ERROR] 
  >>> Unknown identifier!
  Cannot find a definition for `builder_add_objects_from_file' in the header file.
./Graphics/UI/Gtk/Builder.chs:186: (column 18) [ERROR] 
  >>> Unknown identifier!
  Cannot find a definition for `builder_add_objects_from_string' in the header file.

I checked the GTK+ API doc, and these two functions only appear in version >= 2.14. Debian stable (lenny) still has libgtk version 2.12

http://haskell.org/gtk2hs/download/ claims that building gtk2hs requires GTK+ >= 2.8, which apparently is not the whole truth.

The source code of the offending file (Builder.chs) says "All functions in this module are only available in Gtk 2.12 or higher", which is also not quite true.

Change History

in reply to: ↑ description   Changed 4 years ago by guest

Replying to guest:

cabal install gtk installs a couple of packages fine (glib, gio, cairo, pango), then fails with the following error message: {{{ Configuring gtk-0.11.0... Preprocessing library gtk-0.11.0... gtk2hsC2hs: Errors during expansion of binding hooks: ./Graphics/UI/Gtk/Builder.chs:165: (column 18) [ERROR]

Unknown identifier!

Cannot find a definition for `builder_add_objects_from_file' in the header file. ./Graphics/UI/Gtk/Builder.chs:186: (column 18) [ERROR]

Unknown identifier!

Cannot find a definition for `builder_add_objects_from_string' in the header file. }}} I checked the GTK+ API doc, and these two functions only appear in version >= 2.14. Debian stable (lenny) still has libgtk version 2.12 http://haskell.org/gtk2hs/download/ claims that building gtk2hs requires GTK+ >= 2.8, which apparently is not the whole truth. The source code of the offending file (Builder.chs) says "All functions in this module are only available in Gtk 2.12 or higher", which is also not quite true.

Done, please close. -- Andy

  Changed 4 years ago by guest

Thanks, gtk from darcs now builds and works for me.

  Changed 4 years ago by axel

  • status changed from new to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.