Ticket #1215 (closed defect: invalid)

Opened 4 years ago

Last modified 19 months ago

No way of getting details from EAny

Reported by: guest Owned by: somebody
Priority: normal Milestone: 0.12.0
Component: general (Gtk+, Glib) Version:
Keywords: Cc: kviki@…

Description

For those signals, which use EventM EAny (for example, the textTagEvent signal) there's no way to find out the details and the concrete type of the actual event that happened.

Change History

Changed 19 months ago by dmwit

  • status changed from new to closed
  • resolution set to invalid

The EventM is very restrictive by design; the documentation describes why in detail.

That said, the textTagEvent signal is particularly rich in this regard: in the handler, you know that the event is specifically a textTagEvent, which text tag is associated with the event, which object fired the event, a text iterator telling where the event fired, and of course the draw window associated with the event (because we're in the EventM EAny monad). Even in pure C, there's no more information than that to know!

Note: See TracTickets for help on using tickets.