Ticket #1219 (closed defect: invalid)

Opened 3 years ago

Last modified 17 months ago

gtk fails to build - ghc: out of memory

Reported by: guest Owned by: duncan
Priority: normal Milestone: 1.0
Component: build system Version:
Keywords: Cc: davidsteiner2010@…

Description

i'm trying to build gtk (gtk2hs), but everytime it spits out this error message, that it's out of memory. i've tried with different ghc-options (setting +RTS etc), but they don't help. don't know how to solve this.

OS: OpenBSD 4.9 Arch: amd64 GHC version: 6.12.3 Cabal version: 1.8.0.6

Attached is the build log.

Attachments

typescript (27.4 kB) - added by guest 3 years ago.
build log

Change History

Changed 3 years ago by guest

build log

Changed 3 years ago by guest

i tried again as the root user, and it worked. looks like the setting in /etc/login.conf was limiting processes to ~512MB memory. fixed!

Changed 17 months ago by dmwit

  • status changed from new to closed
  • resolution set to invalid
Note: See TracTickets for help on using tickets.