Ticket #1232 (closed defect: invalid)

Opened 3 years ago

Last modified 19 months ago

Segmentation fault using System.GIO.File.File.File

Reported by: guest Owned by: somebody
Priority: normal Milestone: 0.12.0
Component: general (Gtk+, Glib) Version:
Keywords: Cc: ivanperezdominguez@…

Description

I'm running into segfaults when I try to use File as defined in the module System.GIO.File.File. The following samples fail, regardless of what I use as URI.

-- Sample 1

import System.GIO.File.File
main =
 putStrLn $ fileParseName $ fileFromURI "file:///home/me/test.jpg"

-- Sample 2

import System.GIO.File.AppInfo
import System.GIO.File.File
import qualified Data.ByteString.Char8 as B

main = do
 appInfo <- fileQueryDefaultHandler file Nothing
 appInfoLaunch appInfo [file] Nothing
 where file = fileFromPath $ B.pack "file.jpg"

I tried this in two computers, both with Ubuntu. One is a x86, the other an amd64. Same result. GDB gives me:

Program received signal SIGSEGV, Segmentation fault. 0x0000000000000000 in ?? ()

Change History

Changed 19 months ago by dmwit

  • status changed from new to closed
  • resolution set to invalid

You must call System.Glib.GType.glibTypeInit before using anything that does stuff with glib.

Note: See TracTickets for help on using tickets.