Ticket #1243 (closed defect: fixed)

Opened 2 years ago

Last modified 12 months ago

Program crash on popupShownNotify

Reported by: guest Owned by: somebody
Priority: normal Milestone: 0.12.0
Component: general (Gtk+, Glib) Version: 0.11.0
Keywords: Cc: JoshBBall@…

Description

Steps to reproduce:

1. Run the attached program. 2. Click on the combo box.

Expected result: Console should show message "popupShownNotify" Actual result: Program crashes with the following error message:

** ERROR **: gtk2hs_value_as_haskellobj: unable to handle GValue with type GParam please report this as a bug to gtk2hs-devel@… Trace/breakpoint trap

This was on version 0.12.1, but the tracker doesn't let me select that version.

Attachments

PopupShownNotify.hs (295 bytes) - added by guest 2 years ago.

Change History

Changed 2 years ago by guest

Changed 12 months ago by dmwit

  • status changed from new to closed
  • resolution set to fixed

The property notification system has been completely overhauled, and this seems to be working now. Although "popupShownNotify" no longer exists, the replacement signal "notifyProperty comboBoxPopupShown" does not cause a segfault here.

Note: See TracTickets for help on using tickets.