Ticket #1257 (closed defect: fixed)

Opened 3 years ago

Last modified 17 months ago

cannot build glib-0.12.2 with ghc-7.4.1

Reported by: guest Owned by: somebody
Priority: normal Milestone: 0.11.0
Component: general (Gtk+, Glib) Version: 0.11.0
Keywords: Cc:

Description

with the following error message:

[...] [21 of 21] Compiling System.Glib ( System/Glib.hs, dist/build/System/Glib.o ) System/Glib/hsgclosure.c: In function ‘gtk2hs_closure_marshal’:

System/Glib/hsgclosure.c:110:0:

warning: passing argument 1 of ‘rts_evalIO’ from incompatible pointer type

System/Glib/hsgclosure.c:110:0:

error: void value not ignored as it ought to be

cabal: Error: some packages failed to install: glib-0.12.2 failed during the building phase. The exception was: ExitFailure? 1

Change History

Changed 17 months ago by dmwit

  • status changed from new to closed
  • resolution set to fixed

This is fixed in the repository. Thanks for the report -- especially for the version details that let me verify the problem!

Note: See TracTickets for help on using tickets.