Ticket #1274 (closed enhancement: fixed)

Opened 5 years ago

Last modified 5 years ago

Inconsistency in syntax/naming: buttonActivated vs entryActivate

Reported by: guest Owned by: somebody
Priority: minor Milestone: 0.11.0
Component: general (Gtk+, Glib) Version: 0.11.0
Keywords: Cc: morgawr@…


I think it's rather inconsistent to have a signal called buttonActivated for buttons and entryActivate for entries (see: no final 'd'). I'm not sure if this applies to other widget signal as well but I think that it should be better to keep the naming consistent between all signal types. (be it, drop the d or add it)

Change History

Changed 5 years ago by guest

Good idea. I've pushed a patch that adds menuItemActivated, menuItemActivatedItem, statusIconActivated, and entryActivated, and deprecates the -Activate variants of each.

Changed 5 years ago by dmwit

  • status changed from new to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.