Changes between Initial Version and Version 1 of Ticket #1278

Show
Ignore:
Timestamp:
02/04/13 02:53:34 (22 months ago)
Author:
dmwit
Comment:

dupe of #1279

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #1278

    • Property status changed from new to closed
    • Property resolution changed from to duplicate
  • Ticket #1278 – description

    initial v1  
    1  
    21 
    32I wrote a multithreaded GUI program for a research project using gtk2hs, and it works fine on fedora 17, which uses ghc 7.0.4. It crashes almost as soon as it starts when compiled and run on fedora 18 (ghc 7.4.1). There's a message on the console that it was killed because of a segmentation fault and that's about all it tells me. I tracked down the code that causes crash, and it seems to happen because I add an action to the gtk loop: