Ticket #1291 (new defect)

Opened 12 months ago

Last modified 11 months ago

Ambiguous occurrence `moreRecentFile'

Reported by: guest Owned by: somebody
Priority: normal Milestone: 0.13.0
Component: general (Gtk+, Glib) Version: 0.12.4
Keywords: Cc:

Description

Hi!

I just tried installing leksah and got error while installing cairo.

~ ➤ cabal install cairo-0.12.4                                                                                                                                                         
Resolving dependencies...
Configuring cairo-0.12.4...
Failed to install cairo-0.12.4
Last 10 lines of the build log ( /home/kb/.cabal/logs/cairo-0.12.4.log ):
cabal: Error: some packages failed to install:
cairo-0.12.4 failed during the configure step. The exception was:
user error (
/tmp/cairo-0.12.4-10724/cairo-0.12.4/SetupWrapper.hs:94:45:
Ambiguous occurrence `moreRecentFile'
It could refer to either `SetupWrapper.moreRecentFile',
defined at /tmp/cairo-0.12.4-10724/cairo-0.12.4/SetupWrapper.hs:149:1
or `Distribution.Simple.Utils.moreRecentFile',
imported from `Distribution.Simple.Utils' at
/tmp/cairo-0.12.4-10724/cairo-0.12.4/SetupWrapper.hs:8:1-32

/tmp/cairo-0.12.4-10724/cairo-0.12.4/SetupWrapper.hs:95:45:
Ambiguous occurrence `moreRecentFile'
It could refer to either `SetupWrapper.moreRecentFile',
defined at /tmp/cairo-0.12.4-10724/cairo-0.12.4/SetupWrapper.hs:149:1
or `Distribution.Simple.Utils.moreRecentFile',
imported from `Distribution.Simple.Utils' at
/tmp/cairo-0.12.4-10724/cairo-0.12.4/SetupWrapper.hs:8:1-32
)

Change History

Changed 12 months ago by guest

It's possibly due to fresh cabal 1.18.

Changed 12 months ago by guest

Seems to be the same issue on #1289.

Changed 11 months ago by guest

I have this bug with cabal-install 1.18, and not with 1.16. ghc-7.6.3 in both cases. Does that make it a Cabal bug? ( bergey@… )

Note: See TracTickets for help on using tickets.