Ticket #102 (closed defect: duplicate)

Opened 5 years ago

Last modified 2 years ago

haddock-2.4.2 shipped with ghc-6.10.2 is extremely slow

Reported by: maeder Owned by:
Priority: major Milestone:
Version: Keywords:
Cc:

Description

Calling haddock for our Hets project http://www.dfki.de/sks/hets takes around 40 minutes after upgrading to ghc-6.10.2. (haddock 2.3.0 with ghc-6.10.1 took below 1 minute.)

Unfortunately, reproducing this behavior requires to install many packages. You need fgl, xml, and time to compile anything at all within Hets.

Check out: https://svn-agbkb.informatik.uni-bremen.de/Hets/trunk https://svn-agbkb.informatik.uni-bremen.de/uni/trunk

You need the uni packages and hxtfilter-8.2.0 to cause haddock to become slow. (Look inside Hets/INSTALL)

Within Hets I call:

cabal configure -v -f -gtkglade -f -programatica -f -shellac -f -haxml -f -tabular -f -tar

to avoid dependencies on even further packages.

Compiling 433 files using "time cabal build" takes:

real    4m34.159s
user    4m21.308s
sys     0m7.456s

Running now haddock using "time cabal haddock --executables" takes about 40 minutes

I'll attach the corresponding log files. (The sources contain one template haskell file Hets/SoftFOL/MathServCommunication.hs)

Change History

Changed 5 years ago by maeder

  • status changed from new to closed
  • resolution set to duplicate

accidental resubmission (duplicate of #101)

Changed 2 years ago by anonymous

  • milestone 2.5.0 deleted

Milestone 2.5.0 deleted

Note: See TracTickets for help on using tickets.