Ticket #105 (closed enhancement: fixed)

Opened 5 years ago

Last modified 22 months ago

Problem with URL fragments containing ':' in Opera.

Reported by: petr Owned by:
Priority: trivial Milestone:
Version: 2.4.2 Keywords: opera fragment colon
Cc:

Description

Hi, I'm having problems viewing Haddoc generated documentation in the Opera browser. Clicking an inter-document link simply does nothing.

I'm almost sure that the problem is caused by having colons (':' - %3A) characters in URL fragments (and perhaps by other control characters, but I haven't noticed any except ':').

While AFAIK this conforms to URI standards and so the bug is actually in Opera, not in Haddock, it looks like it will take a long time before it will be fixed in Opera (I've reported the bug months ago). Therefore, replacing the ':' character in URL fragments with something Opera friendly (perhaps '_') would help Opera users before the bug in Opera will be fixed (if ever).

Thanks, Petr

Change History

Changed 5 years ago by waern

Hi, this sounds like #45 to me. Have you tried the latest version of Haddock (2.4.2)? If you get this bug with the latest version of Haddock, I'd like to know which version of Opera you are using.

Changed 5 years ago by petr

I see, I'm sorry I didn't look up that a similar bug has already been reported. I'm using the latest version of Opera:

Version information:

Version	    9.64
Build	    2480
Platform    Linux
System	    i686, 2.6.26-2-vserver-686
Qt library  3.3.8b
Java	    Java Runtime Environment installed

Browser identification::

Opera/9.64 (X11; Linux i686; U; en) Presto/2.1.1

Is there some documentation on the web generated by the latest version of Haddock so that I can check it out with the browser? I wasn't able to compile the sources myself, probably due to my ignorance and inexperience with Cabal.
(I couldn't get past the error:

src/Haddock/Utils.hs:74:7:
   Could not find module `Distribution.ReadE':
     it is a member of package Cabal-1.6.0.3, which is hidden

)

Changed 5 years ago by petr

  • status changed from new to closed
  • version set to 2.4.2
  • resolution set to fixed
  • milestone changed from 2.5.0 to 2.4.2

Thanks, there links to fragments work as they should, so this is already taken care of in version 2.4.2. Sorry for bothering you.

Changed 22 months ago by anonymous

  • milestone 2.4.2 deleted

Milestone 2.4.2 deleted

Note: See TracTickets for help on using tickets.