Ticket #119 (closed defect: duplicate)

Opened 5 years ago

Last modified 19 months ago

empty lines in a do block

Reported by: bastl Owned by:
Priority: major Milestone:
Version: 2.4.2 Keywords:
Cc:

Description

empty lines in a do block are not accepted.

Attachments

Main.hs (69 bytes) - added by bastl 5 years ago.
A dumb Main module
Main.2.hs (69 bytes) - added by bastl 5 years ago.
A dumb Main module
test.cabal (192 bytes) - added by bastl 5 years ago.
cabal file

Change History

Changed 5 years ago by bastl

A dumb Main module

Changed 5 years ago by bastl

A dumb Main module

Changed 5 years ago by bastl

cabal file

Changed 5 years ago by bastl

to reproduce issue 'cabal haddock --executables'

Changed 4 years ago by waern

  • status changed from new to closed
  • resolution set to duplicate

The problem here is not the empty line, but the fact that you have a doc comment as the first thing in a module without a "module M where" declaration - this can't be handled by Haddock due to a parsing conflict. See #10.

Changed 19 months ago by anonymous

  • milestone 2.5.0 deleted

Milestone 2.5.0 deleted

Note: See TracTickets for help on using tickets.