Ticket #133 (closed defect: worksforme)

Opened 4 years ago

Last modified 22 months ago

Long comments at the top of a module

Reported by: McManiaC Owned by:
Priority: major Milestone:
Version: Keywords:
Cc: johan.tibell@…

Description

Long comments at the top of a module (before the module ... where ... part) will cause Haddock to fail with the error:

src/System/Event/PSQ.hs:1:0:
    File name does not match module name:
    Saw: `Main'
    Expected: `System.Event.PSQ'

System.Event.PSQ

If you put the comment between the module and the imports you'll get another error:

dist/build/tmp9407/src/System/Event/PSQ.hs:91:0:
    parse error on input `import'

Tested with the latest darcs build.

Change History

Changed 4 years ago by tibbe

  • cc johan.tibell@… added

Changed 4 years ago by waern

  • milestone 2.7.0 deleted

Changed 3 years ago by waern

I can't reproduce this. Could it have been fixed with recent GHC versions?

Changed 22 months ago by SimonHengel

  • status changed from new to closed
  • resolution set to worksforme

I also can't reproduce this. If it still persists, please re-open the issue, and attach a minimal test case.

Note: See TracTickets for help on using tickets.