Ticket #137 (closed defect: duplicate)

Opened 4 years ago

Last modified 2 years ago

Cannot place -- ^ comment after GADT constructor

Reported by: nr Owned by:
Priority: major Milestone:
Version: 2.6.0 Keywords:
Cc:

Description

This might be the same problem as ticket #43; I couldn't quite tell. The offending code is

{-# LANGUAGE GADTs #-}
module Haddock
where

data Lit a where
  I :: Int  -> Lit Int  -- ^ an integer
  B :: Bool -> Lit Bool -- ^ a Boolean

And Haddock reports

Haddock.hs:6:24: parse error on input `-- ^ an integer'

Attachments

Haddock.hs (142 bytes) - added by nr 4 years ago.
Just the code shown in the ticket -- makes Haddock fail with a parse error

Change History

Changed 4 years ago by nr

Just the code shown in the ticket -- makes Haddock fail with a parse error

Changed 2 years ago by anonymous

  • milestone 2.7.0 deleted

Milestone 2.7.0 deleted

Changed 2 years ago by nwf

  • status changed from new to closed
  • resolution set to duplicate

This is a duplicate of ticket 43

Note: See TracTickets for help on using tickets.