Ticket #163 (closed defect: worksforme)

Opened 3 years ago

Last modified 18 months ago

Hyperlinked identifiers in headings are not rendered correctly in contents table

Reported by: mitar Owned by:
Priority: major Milestone:
Version: 2.8.0 Keywords:
Cc: mmitar@…

Description

Hyperlinked identifiers in headings are not rendered correctly in contents table In Firefox 3.6.12 and Safari 5.0.2. For example if I have a heading:

-- * My heading with 'Element's

this is rendered with Element being a link to Element documentation, My heading with link to the heading, but s at the end is not a link to the heading anymore. HTML is like:

<li><a href="#g:4">My heading with <code><a href="Element.html#t:Element">Element</a></code>s</a></li>

But internally Firefox (Firebug) sees it as:

<li><a href="#g:4">My heading with <code></code></a><a href="Element.html#t:Element">Element</a>s
</li>

Change History

Changed 19 months ago by anonymous

  • milestone 2.8.0 deleted

Milestone 2.8.0 deleted

Changed 18 months ago by SimonHengel

  • status changed from new to closed
  • resolution set to worksforme

I can't reproduce this (with FF 15.0.1 and 2.11.0). If you think the issue is still eminent, re-open the issue and attach a minimal test case and exact instructions how to reproduce the issue.

Note: See TracTickets for help on using tickets.