Ticket #228 (closed defect: fixed)

Opened 2 years ago

Last modified 10 months ago

Wrong links for fully qualified identifiers that are not in scope

Reported by: SimonHengel Owned by:
Priority: major Milestone:
Version: 2.14.0 Keywords:
Cc: daniel@…

Description

If we have something like

'Control.Concurrent.MVar.addMVarFinalizer'

Haddocks thinks it is a type and will prepend a {{t:}} to the generated link.

A real world example: http://hackage.haskell.org/packages/archive/base/4.6.0.0/doc/html/System-Mem-Weak.html#v:addFinalizer

Change History

Changed 21 months ago by locush

I've just stumbled across the same bug in Text.Printf.Mauke.TH (printf link goes to #t:printf instead of #v:printf) and, more importantly, Control.Lens.Prism from lens (e.g. the re, review, and preview links).

Very annoying.

Changed 15 months ago by dmwit

Just to add: it doesn't seem related to scoping. The links for cmd and command at http://hackage.haskell.org/packages/archive/shake/0.10.6/doc/html/Development-Shake.html#v:need exhibit this problem despite being links to other functions in the same module.

Changed 15 months ago by dmwit

  • cc daniel@… added

Changed 10 months ago by Fūzetsu

  • status changed from new to closed
  • resolution set to fixed

Ah, I think #253 was the duplicate of this which I have fixed so I'm closing this.

Changed 10 months ago by anonymous

  • milestone 2.13.2 deleted

Milestone 2.13.2 deleted

Note: See TracTickets for help on using tickets.