Ticket #269 (closed defect: duplicate)

Opened 9 months ago

Last modified 4 months ago

Unexported symbols crawl out to docs

Reported by: nyvo Owned by:
Priority: major Milestone:
Version: 2.13.1 Keywords:
Cc:

Description

Here is a module, in which I reexport just a single function from another module: https://github.com/nikita-volkov/graph-db/blob/b0cbb7f4ea419d8cd49ba479a3f6aa5e07821c6d/src/GraphDB.hs

module GraphDB 
  (
    ...
    module GraphDB.GenerateBoilerplate,
  ) 
  where
...
import GraphDB.GenerateBoilerplate (generateBoilerplate)

The generated doc contains all the functions from this reexported module instead.

To reproduce this, just check out the referred project.

My Haddock version is 2.13.2.1.

Change History

Changed 4 months ago by Fūzetsu

  • status changed from new to closed
  • resolution set to duplicate

Duplicate of #174

Note: See TracTickets for help on using tickets.