Ticket #49 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

Links with to page anchors don't work in Opera 9.5x

Reported by: larsko Owned by:
Priority: minor Milestone:
Version: 2.0.0.0 Keywords:
Cc: lars@…

Description

The anchors Haddock generates to e.g. link to function documentation from the synopsis contain a percent-escaped colon after the #. Opera apparently unescapes it and then tries to find the anchor with the colon (e.g. "foo.html#v%3Afoobar" becomes "foo.html#v:foobar"). The anchor definition also uses the %-escaped colon though and is therefore not found.

A possible solution to this problem is to escape the percent sign in the link, i.e. have "foo.html#v%253Afoobar" in the link and "foo.html#v%3Afoobar" in the anchor definition. On the other hand it would probably be cleaner to only use characters which do not need to be escaped in the generated links.

Change History

Changed 6 years ago by olsner@…

  • status changed from new to closed
  • resolution set to duplicate

Duplicate of #45.

Note: See TracTickets for help on using tickets.