Ticket #9 (closed defect: fixed)

Opened 6 years ago

Last modified 2 years ago

Parser doesn't support doc comments on type aliases

Reported by: waern Owned by:
Priority: critical Milestone:
Version: 2.1.0 Keywords:
Cc: david.waern@…, gwern0@…

Description

Parser doesn't support doc comments on types in type aliases:

type MyInt = Int -- ^ comment

This was forgotten during the SoC project, and needs to be fixed in GHC's parser, hence the 2.3.0 milestone.

Change History

Changed 6 years ago by anonymous

  • milestone 2.3.0 deleted

Changed 6 years ago by waern

  • cc david.waern@… added

test email notification system

Changed 6 years ago by gwern

  • cc gwern0@… added

Changed 6 years ago by waern

  • milestone set to 2.6.0

Changed 5 years ago by waern

  • priority changed from major to critical

This one deserves critical status since it's a regression which makes previously buildable docs unbuildable.

Changed 5 years ago by waern

Changed 5 years ago by waern

  • status changed from new to closed
  • resolution set to fixed

Fixed in GHC HEAD.

Changed 2 years ago by anonymous

  • milestone 2.6.0 deleted

Milestone 2.6.0 deleted

Note: See TracTickets for help on using tickets.