Ticket #98 (closed defect: duplicate)

Opened 5 years ago

Last modified 22 months ago

haddock 2.4.2 crashes when documenting encoding-0.5.1

Reported by: hgolden Owned by:
Priority: minor Milestone:
Version: Keywords:
Cc:

Description

I just upgraded haddock to 2.4.2 (using Gentoo overlay). It was compiled with ghc-6.10.1.

When documenting encoding-0.5.1, haddock crashes with the following message:

haddock: internal Haddock or GHC error: Maybe.fromJust: Nothing

(N.B.: parts of encoding-0.5.1 take a _really_ long time to compile in GHC. Is this possibly a capacity/memory issue?)

Change History

Changed 5 years ago by waern

  • status changed from new to closed
  • resolution set to duplicate

Duplicate of #68. You need to build Haddock 2.4.2 with GHC 6.10.2 (a release candidate is available) to get the fix.

Changed 22 months ago by anonymous

  • milestone 2.5.0 deleted

Milestone 2.5.0 deleted

Note: See TracTickets for help on using tickets.