Ticket #52 (closed enhancement: fixed)

Opened 6 years ago

Last modified 4 years ago

Don't accept key sequences which have partially failed

Reported by: judah Owned by:
Priority: minor Milestone:
Version: Keywords:
Cc:

Description

In many cases, it's feasible to eliminate the extra characters from unknown key sequences. Specifically, if we fail to parse a single buffer of input, we should ignore the whole thing.

One specific possibility is to throw out the buffer if a string 'partially matches' (eg ctrl-left ^[[5D, if not defined, will match up to the first two characters (of, eg, left ^[[D).

Change History

Changed 6 years ago by judah

  • type changed from defect to enhancement

Changed 4 years ago by judah

  • status changed from new to closed
  • resolution set to fixed

Dupe of #106.

Note: See TracTickets for help on using tickets.