Ticket #56 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

haskeline does not provide fancy line editing in ghci-6.10.1

Reported by: judah Owned by:
Priority: minor Milestone: 0.6.*
Version: Keywords:
Cc:

Description

Using ghci-6.10.1, when Test.hs is run under ghci-6.10.1, fancy line editing is not used.

The problem does not occur in ghci-6.8.1 or with ghci-haskeline.

Change History

Changed 6 years ago by judah

  • milestone set to 0.6.*

Changed 6 years ago by judah

The terminfo backend is used, and it appears to be a buffering problem...very strange.

Changed 5 years ago by judah

This issue is caused by a ghci bug:

http://hackage.haskell.org/trac/ghc/ticket/3009

Currently the POSIX backend only sets stdin to NoBuffering if it's not already set. We can work around this by always setting NoBuffering.

Changed 5 years ago by judah

  • status changed from new to closed
  • resolution set to fixed

Fix by:

Sat Feb  7 13:33:43 PST 2009  judah.jacobson@gmail.com
  * Fix #56: Always set POSIX terminal attributes.
Note: See TracTickets for help on using tickets.