Ticket #73 (closed defect: fixed)

Opened 6 years ago

Last modified 3 years ago

If several lines are pasted in, Haskeline may ignore all but the first

Reported by: judah Owned by:
Priority: minor Milestone: 0.6.*
Version: 0.6 Keywords:
Cc:

Description

Take a program running Haskeline, and paste in several lines at once. After the first line, most or all of the input will be gone.

The problem is that on POSIX, in order to process Unicode input efficiently we read ahead in the buffer and don't put back what we haven't used.

Change History

Changed 6 years ago by judah

  • milestone set to 0.6.*

Probably the best fix is to pull from the buffer only as far as the first '\n' byte (or push back everything after that '\n').

This is OK since we already require encodings that treat '\n' as one byte.

Changed 5 years ago by judah

  • status changed from new to closed
  • resolution set to fixed

Changed 3 years ago by judah

  • status changed from closed to reopened
  • resolution fixed deleted

Looks like this issue has resurfaced:

http://hackage.haskell.org/trac/ghc/ticket/5548

After looking at the darcs history, I figured out what caused the regression. I'll work on the fix, which should be pretty minor.

Changed 3 years ago by judah

  • status changed from reopened to closed
  • resolution set to fixed

Now fixed in haskeline-0.6.4.4.

Note: See TracTickets for help on using tickets.