Stop! Tickets are now managed at GitHub.

Please enter new tickets, and find and edit existing tickets there:


Ticket #11 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

glut installation on Windows via cabal doesn't work by default

Reported by: duncan Owned by: panne
Priority: minor Milestone: 2010.2.0.0
Component: GLUT Keywords:
Cc:

Description

This is really a bug in GLUT but GLUT doesn't have a bug tracker yet it seems. Grr.

The ./configure script for GLUT does not notice the include dirs for GHC's mingw installation on Windows. See http://haskell.org/pipermail/haskell-cafe/2009-April/059883.html

Setting env vars makes it work for the configure script but presumably the base package or the rts already specifies this path. If we were doing this directly in Cabal or the Setup.hs then presumably it'd work. It'd be really good to get rid of the ./configure script so that this kind of thing just works without having to set env vars. Alternatively perhaps Cabal should set these env vars when it calls configure.

See also http://hackage.haskell.org/trac/hackage/ticket/458

Change History

Changed 6 years ago by refold

The same applies to OpenGL.

Changed 6 years ago by dons

  • owner set to SvenPanne
  • component set to GLUT

Changed 6 years ago by panne

  • owner changed from SvenPanne to panne

Changed 6 years ago by panne

  • status changed from new to assigned

Changed 6 years ago by panne

If I read this ticket correctly, the problem is how to tell Cabal where the GLUT header and library are, right? Autoconf has a well-defined set of environment variables to deal with such cases, see http://www.gnu.org/software/hello/manual/autoconf/Preset-Output-Variables.html. As I see it, this is a Cabal bug, because it doesn't pass the additional paths in autoconf variables, even when the build type is "Configure". So I'm inclined to close this ticket. Any comments?

Removing autoconf from the OpenGL/GLUT/OpenAL/ALUT packages is a different story and not something for the near future, I think. See http://haskell.org/pipermail/haskell-cafe/2009-April/060626.html

Changed 6 years ago by dons

New GLUT release: http://hackage.haskell.org/cgi-bin/hackage-scripts/package/GLUT-2.1.2.1

Does this fix things on Windows?

Changed 6 years ago by dons

  • milestone set to 2009.2.0

Changed 6 years ago by refold

Does this fix things on Windows?

IIRC, you still have to set C_INCLUDE_PATH manually. Sven's comment above indicates that this is a Cabal bug.

Changed 6 years ago by dons

  • milestone changed from 2009.2.0 to 2009.2.1

Changed 5 years ago by dons

  • milestone changed from 2009.2.0.1 to 2009.4.0

Changed 4 years ago by refold

  • milestone changed from 2009.4.0 to 2010.2.0.0

Milestone 2009.4.0 deleted

Changed 4 years ago by refold

  • status changed from assigned to closed
  • resolution set to fixed

With 2010.2.0, cabal install GLUT works out of the box on Windows.

Note: See TracTickets for help on using tickets.