Stop! Tickets are now managed at GitHub.

Please enter new tickets, and find and edit existing tickets there:


Ticket #123 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Haskell Platform 2010.1.0.0 platform does not include C++ support

Reported by: jodonoghue Owned by: refold
Priority: major Milestone:
Component: Windows installer Keywords:
Cc:

Description

Unable to cabal install wx (wxHaskell installation) on 2010.1.0.0 Haskell Platform (this has succeeded on previous versions of HP).

Analysis showed error compiling the wrapper around C++ code in wxWidgets, due to cabal unable to find cc1plus.exe.

This is blocking for anyone trying to compile C++ code via Cabal installers on Windows using the latest HP, and breaks wxHaskell installation on Windows using Haskell Platform.

Attached reply from Neil Mitchell to mail on haskell mailing list:

On checking, Haskell Platform\2010.1.0.0\mingw\libexec\gcc\mingw32\3.4.5 does not contain cc1plus.exe. Previous versions of the platform have done so. Is this an accidental change or a deliberate policy decision?

ghc-6.12.1 on Windows did not include the mingw C++ compiler. This was a mistake. It is included once more in ghc-6.12.2.

ghc-6.12.1 didn't include cc1plus.exe or libstdc++.a. The lack of libstdc++.a caused a failure in something I was building, so I raised a bug and it's now included in 6.12.2. I didn't explicitly compile any C++ code, so it's possible that still doesn't work. It wasn't a policy decision, merely an accident, and I'm sure if you alert people it will be rectified (since otherwise it's a regression).

Change History

Changed 4 years ago by refold

  • owner changed from dons to refold
  • status changed from new to assigned

Changed 4 years ago by refold

  • status changed from assigned to closed
  • resolution set to fixed

Fixed by updating to GHC 6.12.3.

Changed 4 years ago by refold

  • component changed from GHC to Windows installer
Note: See TracTickets for help on using tickets.