Stop! Tickets are now managed at GitHub.

Please enter new tickets, and find and edit existing tickets there:


Ticket #125 (closed defect: wontfix)

Opened 5 years ago

Last modified 2 years ago

./configure fails on Ubuntu Lucid Lynx, due to 'unknown package: haskell98' error

Reported by: AndyL Owned by: duncan
Priority: minor Milestone:
Component: Generic source tarball Keywords:
Cc:

Description

After using apt-get to install GHC version 6.12.1, I downloaded/untarred haskell-platform-2010.1.0.0.tar.gz and ran ./configure, which quickly failed with the message:

configure: error: Your installation of ghc does not appear to work.

It cannot compile a simple program (see config.log for the details). If you installed ghc from a generic binary tarball then it is worth checking that you have the 'gmp' C library and header files installed.

(Note that I do have libgmp3-dev installed.)

Looking in config.log, it's the compilation of the "Hello world" proglet that is failing:

. . . configure:2456: /usr/bin/ghc -o conftest conftest.hs <command line>: unknown package: haskell98 configure:2459: $? = 1 configure: failed program was: main = putStr "Hello world!\n" -- this file generated by TRY-COMPILE-GHC end of failed program. configure:2468: result: no configure:2474: error: Your installation of ghc does not appear to work.

Attachments

config.log (4.9 kB) - added by AndyL 5 years ago.
config.log output from ./configure

Change History

Changed 5 years ago by AndyL

config.log output from ./configure

Changed 4 years ago by dons

  • priority changed from major to minor

Looks like a distro package problem. Try updating the version of GHC on your system.

Changed 2 years ago by MtnViewMark

  • status changed from new to closed
  • resolution set to wontfix

closing as very old and now out-of-date versions -- please reopen if problem is reproducible on current systems and platforms.

Note: See TracTickets for help on using tickets.