Stop! Tickets are now managed at GitHub.

Please enter new tickets, and find and edit existing tickets there:


Ticket #129 (assigned defect)

Opened 4 years ago

Last modified 21 months ago

WinGHCi won't start if installed without enviroment variables set

Reported by: lummar Owned by: refold
Priority: minor Milestone: 2013.2.0.0
Component: Windows installer Keywords:
Cc:

Description

Problem Description: When try to start WinGHCi, an error occurred with message: GHCiCreateProcess failed with failed with error 2. Grammer issues either.

OS: Windows Server 2008 R2 Ent(Simplified Chinese), X64

Haskell version: Haskell Platform 2010.1.0.0.

Change History

Changed 4 years ago by refold

  • owner changed from dons to refold
  • status changed from new to assigned
  • component changed from Platform to Windows installer

What environment variables do you have in mind? AFAIR WinGHCi reads information from the registry.

Changed 4 years ago by refold

  • priority changed from major to minor

Changed 4 years ago by refold

  • milestone set to 2010.4.0.0

Changed 4 years ago by refold

This probably happens when doing "Just unpack" install. Will need to patch WinGHCi to look in $CURRENT_DIR and $CURRENT_DIR/../bin.

Changed 4 years ago by VZ

The real problem here seems to be that the PATH is not set to include the GHCi directory. The only way to make WinGHCi run without modifying the PATH currently seems to be to copy it to the bin directory containing ghci.exe.

Changed 2 years ago by MtnViewMark

  • milestone 2010.4.0.0 deleted

Milestone 2010.4.0.0 deleted

Changed 21 months ago by refold

  • milestone set to 2013.2.0.0
Note: See TracTickets for help on using tickets.