Stop! Tickets are now managed at GitHub.

Please enter new tickets, and find and edit existing tickets there:


Ticket #134 (closed defect: fixed)

Opened 4 years ago

Last modified 17 months ago

Haskell Platform 2010.2.0.0 is affected by GLUT 2.1.2.1 bug with libXi and libXmu

Reported by: VVLysikov Owned by: panne
Priority: major Milestone:
Component: GLUT Keywords:
Cc:

Description

I installed HP from source on my Ubuntu Lucid amd64. Then I ran cabal install haskell-platform-test and got a bunch of GLUT unresolved symbol errors at linking stage (log attached).

After a short googling I found some discussions about this issue. It is caused by the dependence of GLUT on libXi and libXmu libraries. I suggest checking existence of this libraries in the top ./configure script of HP.

Related links:
https://bugzilla.redhat.com/show_bug.cgi?id=509281
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=Bug%23405227
http://groups.google.com/group/fa.haskell/browse_thread/thread/1716fa5e5643541e/38373ec65e2537fd?lnk=gst

Attachments

haskell-platform-test.log (30.4 kB) - added by VVLysikov 4 years ago.
cabal-install log

Change History

Changed 4 years ago by VVLysikov

cabal-install log

Changed 20 months ago by MtnViewMark

I don't see how we can depend on those libraries in the generic HP because the need for those libs is specific to the OS install of GLUT. For example, on both Windows and Mac those libraries don't even exist.

Ideas, anyone?

Changed 17 months ago by svenpanne

  • status changed from new to closed
  • resolution set to fixed

I've successfully compiled the 2013.2.0.0 platform on Ubuntu 12.04 LTS (x64), so I think we can safely close this ancient ticket.

Note: See TracTickets for help on using tickets.