Stop! Tickets are now managed at GitHub.

Please enter new tickets, and find and edit existing tickets there:


Ticket #137 (closed defect: fixed)

Opened 4 years ago

Last modified 21 months ago

Linking error when using Text.Regex.Posix

Reported by: axqd Owned by: refold
Priority: major Milestone: 2010.2.0.0
Component: Windows installer Keywords:
Cc:

Description

[OS Version] Windows 7 Ultimate 64-bit

[Haskell Platform Version] 2010.2.0.0

[GHCi Steps]

Prelude Text.Regex.Posix> "good" =~ "oo|ff" :: Bool
Loading package array-0.3.0.1 ... linking ... done.
Loading package bytestring-0.9.1.7 ... linking ... done.
Loading package containers-0.3.0.0 ... linking ... done.
Loading package syb-0.1.0.2 ... linking ... done.
Loading package base-3.0.3.2 ... linking ... done.
Loading package mtl-1.1.0.2 ... linking ... done.
Loading package regex-base-0.93.2 ... linking ... done.
Loading package regex-posix-0.94.2 ... linking ... <interactive>: C:\PROGRA~2\HA
SKEL~1\201020~1.0\lib\extralibs\regex-posix-0.94.2\ghc-6.12.3\HSregex-posix-0.94
.2.o: unknown symbol `_regerror'
: unable to load package `regex-posix-0.94.2'

Prelude Text.Regex.Posix> "good" =~ "oo|ff" :: Bool
Loading package array-0.3.0.1 ... linking ... <interactive>: C:\PROGRA~2\HASKEL~
1\201020~1.0\lib\extralibs\regex-posix-0.94.2\ghc-6.12.3\HSregex-posix-0.94.2.o:
 unknown symbol `_regerror'
: unable to load package `array-0.3.0.1'

Change History

Changed 4 years ago by refold

  • owner changed from dons to refold
  • status changed from new to assigned
  • component changed from Platform to Windows installer

Changed 4 years ago by refold

Was able to reproduce this on XP x64. This is a major regression, we'll have to release an update. In the meantime you can install regex-posix from Hackage.

Changed 4 years ago by refold

  • milestone set to 2010.2.0.0

Changed 4 years ago by axqd

'cabal install regex-posix' can solve this problem, hence it's a valid workaround as you mentioned.

Changed 4 years ago by raould

cabal "solution" does not work for me.

to wit: * i'm using winxp, just installed Haskell Platform today (2010.2.0.0). * trying to use the Example from Test.Framework is how i hit this. * using winghci. * get a link error: Loading package regex-posix-0.94.2 ... linking ... ghc: unable to load package `regex-posix-0.94.2'. * tried cabal install, it installed 0.94.4. * restarting winghci and trying again gives me the same error. i assume it is because the version numbers are not the same. * did ghc-pkg unregister regex-posix-0.94.4, then cabal install regex-posix-0.94-2 --reinstall, but that failed due to missing regex.h (of course?).

so i am guessing that the Haskell Platform for Windows has some configuration file that assumes/requires exactly 0.94.2, and won't notice 0.94.4. (like, when i do ghc-pkg list regex-posix, it lists C:/Program Files/Haskell Platform/2010.2.0.0\lib\package.conf.d: regex-posix-0.94.2.)

?!

Changed 21 months ago by refold

  • status changed from assigned to closed
  • resolution set to fixed

This was fixed long ago.

Note: See TracTickets for help on using tickets.