Stop! Tickets are now managed at GitHub.

Please enter new tickets, and find and edit existing tickets there:


Ticket #147 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

Broken Haddock links (Windows specific?)

Reported by: Orphi Owned by: libraries
Priority: major Milestone:
Component: mtl Keywords:
Cc:

Description

In almost every release of GHC I've used, the links from the Haddock master index to the modules that make up the "mtl" package have been broken. It's always mtl, not any other packages (as far as I can tell), so this suggests a problem with the build process rather than a one-off glitch.

Sometimes the links point to ghc-mtl-XXX when no such folder exists, sometimes the links point to mtl-XXX but that folder is missing.

In HP 2010.2.0.0, the links point to

C:\Program Files\Haskell Platform\2010.2.0.0\doc\html\libraries\mtl-1.1.0.2\...

but this folder does not exist at all. It is completely absent.

This is obviously under Windows, but I'm told others have seen problems with other OSes. It shouldn't be too hard for somebody with access to another OS to check whether all the pages work. (Currently mtl is the only package I'm aware of that is broken.)

Note that other modules under Control.Monad (e.g., Control.Monad.Fix) work perfectly. The problem is mtl.

Change History

Changed 4 years ago by Orphi

  • status changed from new to closed
  • resolution set to duplicate

Duplicate of ticket:176.

Note: See TracTickets for help on using tickets.