Stop! Tickets are now managed at GitHub.

Please enter new tickets, and find and edit existing tickets there:


Ticket #166 (closed defect: fixed)

Opened 3 years ago

Last modified 14 months ago

Windows installer seems to be lacking glut32.dll

Reported by: guest Owned by: refold
Priority: major Milestone: 2012.4.0.0
Component: Windows installer Keywords:
Cc: dagitj@…, gesh@…

Description

On windows packages that use GLUT require the user to download/install glut32.dll manually. I looked on my install of the HP and I couldn't find glut32.dll anywhere, which makes me think the installer just doesn't bundle it.

The right thing is probably to copy glut32.dll into the bindir for everything built with GLUT including paths like ./dist/build/foo/.

Here is an example of such a report: http://syntacticsalt.com/2010/08/30/forest-fire-cellular-automaton-haskell-and-matlab/

Attachments

GLUT screenshot.png (30.0 kB) - added by gesh 14 months ago.
Screenshot of the installer at the moment of the issue

Change History

  Changed 3 years ago by refold

  • status changed from new to assigned

This is a known issue. It is not a good idea to just silently put glut32.dll into $WINDIR/system32; what the installer can do is check if glut32.dll is available system-wide and, if negative, offer the user to install it. We can also install glut32.dll in e.g. $PLATFORMDIR/glut.

The right thing is probably to copy glut32.dll into the bindir for everything built with GLUT including paths like ./dist/build/foo/.

This needs changes in Cabal/cabal-install, i.e. not an installer issue.

  Changed 3 years ago by dons

That sounds like the right approach, refold.

  Changed 18 months ago by refold

  • milestone set to 2012.4.0.0

follow-up: ↓ 5   Changed 18 months ago by refold

  • status changed from assigned to closed
  • resolution set to fixed

Fixed in 2012.4.0.0 RC1.

in reply to: ↑ 4 ; follow-up: ↓ 6   Changed 14 months ago by gesh

  • cc gesh@… added
  • status changed from closed to reopened
  • resolution fixed deleted

Replying to refold: Still occurs with version 2012.4.0.0 I'm not sure whether what I'm seeing is the exact same issue, however, from my limited knowledge as to how the installer works, this issue is exactly what I have. To reproduce: download Haskell from http://lambda.haskell.org/platform/download/2012.4.0.0/HaskellPlatform-2012.4.0.0-setup.exe Run the resulting executable on a Windows machine (Tested on Windows 7 and Windows Server 2008). At the end of the installation, a pop-up appears, with as text: "It looks like glut32.dll is not installed. You will not be able to use the GLUT library. Do you want to copy glut32.dll to the system directory?" Attached is a screenshot of the installer at this moment.

Changed 14 months ago by gesh

Screenshot of the installer at the moment of the issue

in reply to: ↑ 5 ; follow-up: ↓ 7   Changed 14 months ago by refold

  • status changed from reopened to closed
  • resolution set to fixed

Replying to gesh:

At the end of the installation, a pop-up appears, with as text: "It looks like glut32.dll is not installed. You will not be able to use the GLUT library. Do you want to copy glut32.dll to the system directory?"

That's exactly the expected behaviour. If you don't have glut32.dll in the system directory, we offer you to install it.

in reply to: ↑ 6   Changed 14 months ago by gesh

Replying to refold:

Replying to gesh:

At the end of the installation, a pop-up appears, with as text: "It looks like glut32.dll is not installed. You will not be able to use the GLUT library. Do you want to copy glut32.dll to the system directory?"

That's exactly the expected behaviour. If you don't have glut32.dll in the system directory, we offer you to install it.

So this is the behaviour whenever Haskell is the first program to be installed that supplies GLUT? If so, I am sorry for the hassle. It would be better if the message would be changed to something like: "It looks like GLUT isn't installed on your computer. Do you want to install GLUT?" Or if there were an option in the component selection page to install GLUT, which would install GLUT if it were missing.

follow-up: ↓ 9   Changed 14 months ago by refold

I can change the message if you think that it's confusing.

in reply to: ↑ 8   Changed 14 months ago by gesh

Replying to refold:

I can change the message if you think that it's confusing.

It does. The original message seems, to a newbie, to say "This dll, which I'm trying to install, isn't installed. If it doesn't get installed, this feature is disabled. Do you want to install this feature?". It seems like the installer isn't doing its job of installing files based on user preferences. I much prefer my version of the text. Thanks for the quick response.

  Changed 14 months ago by refold

Note: See TracTickets for help on using tickets.