Stop! Tickets are now managed at GitHub.

Please enter new tickets, and find and edit existing tickets there:


Ticket #173 (closed defect: invalid)

Opened 4 years ago

Last modified 4 years ago

2011.2 HP library or load paths messed up

Reported by: guest Owned by: dons
Priority: critical Milestone:
Component: Platform Keywords:
Cc:

Description

After installing 2011.2 HP, several standard library modules don't load:

Prelude> :m Control.Monad Prelude Control.Monad> :m Control.Monad.State

<no location info>:

Could not find module `Control.Monad.State':

it is not a module in the current program, or in any known package.

Prelude Control.Monad>

I remember encountering something like this with the previous platform and getting a workaround from someone on #haskell, but I don't remember the workaround and it should be fixed in the platform.

I'm running Fedora 12.

Change History

Changed 4 years ago by guest

  • status changed from new to closed
  • resolution set to invalid

Seems to be caused by configuration difference between my old 6.12 installation and the new 7.0.3 one. Fixing $PATH seems to have the standard modules working again, but my cabal download don't work now, so I'm reinstalling them.

Note: See TracTickets for help on using tickets.