Stop! Tickets are now managed at GitHub.

Please enter new tickets, and find and edit existing tickets there:


Ticket #174 (closed defect: invalid)

Opened 3 years ago

Last modified 3 years ago

Cabal no longer adds binaries to PATH

Reported by: duncan Owned by: MtnViewMark
Priority: major Milestone:
Component: OSX installer Keywords:
Cc:

Description

A user reported this in the Cabal trac, but the issue is actually the change in the cabal config that the OSX installer makes. I'm not making a judgement on whether this change is good or not, just passing on the report.

http://hackage.haskell.org/trac/hackage/ticket/838

Clearly this user had set things up so that the binaries were on the $PATH and this having changed is confusing.

My guess is that we should set things up so that we use a symlink bindir somewhere sensible. That probably just needs a fix to get the symlinks correct when a per-package bindir is being used.

Change History

Changed 3 years ago by MtnViewMark

  • owner changed from gregorycollins to MtnViewMark

Changed 3 years ago by MtnViewMark

  • status changed from new to closed
  • resolution set to invalid

Actually, Cabal never added binaries to directories in PATH! In the past, it was common for people to modify their cabal configurations to symlink binaries into ~/bin -- but on Mac, that isn't on the PATH by default.

The original reporter seems to be using the cabal configuration that HP now puts on peoples systems, though it only does so if they have no pre-exisiting cabal configuration -- and it should have informed them that the location of built binaries wasn't on their PATH, and it should have printed out instructions for setting that up. See the script in /usr/bin/cabal.wrap that does this. I'd love to learn more if this process didn't work correctly (separate ticket).

(The HP installer, which runs as root, can't reliably adjust PATH settings for each user on the machine.)

Note: See TracTickets for help on using tickets.