Stop! Tickets are now managed at GitHub.

Please enter new tickets, and find and edit existing tickets there:


Ticket #177 (closed defect: invalid)

Opened 3 years ago

Last modified 3 years ago

cabal-install and other binaries not working in Mac Os X Snow Leopard

Reported by: pepeiborra Owned by:
Priority: major Milestone: 2011.4.0.0
Component: (none-specified) Keywords:
Cc:

Description

I installed the Haskell Platform 2011.2.0.1 (April 2011) on a clean Mac OS X Snow Leopard machine. After that, cabal-install refuses to run with

   pepe:~$ cabal
   cabal: Most RTS options are disabled. Link with -rtsopts to enable them.

I don't understand where the error comes from, since I am not giving any -RTS section in the command line. Is this a bug in GHC or a bug in the HP ?

Happy and Alex also display the same behaviour, but haddock seems to work fine.

Change History

Changed 3 years ago by pepeiborra

  • status changed from new to closed
  • resolution set to invalid

Found the reason: a global env variable GHCRTS with the value -M1000M This would be considered as an unsafe RTS setting and therefore the behaviour I am seeing is the expected:

http://www.haskell.org/ghc/docs/7.0-latest/html/users_guide/options-phases.html#options-linker

Note: See TracTickets for help on using tickets.