Stop! Tickets are now managed at GitHub.

Please enter new tickets, and find and edit existing tickets there:


Ticket #199 (closed defect: fixed)

Opened 2 years ago

Last modified 22 months ago

GHCI Startup Crash with HP 2012.2.0.0 on 64bit OS X 10.6

Reported by: guest Owned by: dons
Priority: major Milestone: 2012.4.0.0
Component: GHC Keywords:
Cc:

Description

Installation of the HP appears to have succeeded and things seem to compile and work fine, but GHCI frequently crashes on startup. Here:

GHCi, version 7.4.1: http://www.haskell.org/ghc/ :? for help
Loading package ghc-prim ... linking ... done.
Loading package integer-gmp ... linking ... done.
Loading package base ... linking ... done.
Segmentation fault

There's a 2-3 second delay between the last message and the segfault. Trying to invoke GHCI a couple of times eventually succeeds and results in a working REPL. I have reproduced this on two machines that ran the previous version just fine.

Attachments

ghc_2012-06-03-205527_MacPro09.crash (3.8 kB) - added by guest 2 years ago.

Change History

follow-up: ↓ 2   Changed 2 years ago by MtnViewMark

Any more information would be helpful: in particular, does this work with the 32-bit version? Which version of Xcode do you have installed? Are there any information in the logs? In particular, can you find the crash report file and attach it?

In any event, this is almost certainly a bug in GHC itself... which means the HP team may not have a way to fix this.

in reply to: ↑ 1   Changed 2 years ago by guest

Replying to MtnViewMark:

This is with XCode Version 3.2.6 (1761) on both machines. I tried the 32bit version and was able to get into the REPL ~30x in a row, going back to 64bit still reliably crashes.

The core dump resulting from the GHCI crash is unfortunately 449MB.

follow-up: ↓ 4   Changed 2 years ago by MtnViewMark

Good to hear that the 32-bit version runs okay.

As for the crash, please look for something in ~/Library/Logs/CrashReporter. There should be a much smaller file (a few k at most) that is a text log - that is what I'm after.

Changed 2 years ago by guest

in reply to: ↑ 3   Changed 2 years ago by guest

Replying to MtnViewMark:

Oh, Sorry - Wasn't aware of this particular OS X feature. Report is attached, a quick diff indicates they all look rather similar.

  Changed 2 years ago by guest

I think XCode 3.2.6 is too old. http://www.haskell.org/ghc/download_ghc_7_4_1#macosx_x86_64 says you need 4.1.

-- Igloo

  Changed 2 years ago by MtnViewMark

I filed a bug over in the GHC trac for this.

follow-up: ↓ 8   Changed 2 years ago by MtnViewMark

I don't know if Xcode 4 will run on 10.6. In any event, I tested with Xcode 3.2.6 on my machines (albeit 32-bit)

in reply to: ↑ 7   Changed 2 years ago by guest

Replying to MtnViewMark:

The current HP website says to use XCode 3.2 on 10.6 and recommends to install either the command line tools standalone or from within XCode 4.3 for 10.7. All the 4.x and command line tools on the Apple download site (https://developer.apple.com/downloads/index.action) are for 10.7 only.

What's the recommended install for 10.6?

  Changed 2 years ago by guest

I did a bit more digging and it seem this issue has been discussed on the GHC list:

http://www.haskell.org/pipermail/glasgow-haskell-users/2012-January/021717.html

No definitive answer, though. Since the GHC people require XCode >= 4.1, I looked into obtaining that for 10.6. The current 4.3 is Lion-only, but it seems that 4.0 - 4.2 for 10.6 were available at some point as a payed App Store download, but have since been removed. I read in multiple places it should be available on the developer site, but only shows up if you have a payed developer program subscription. It does not show up with my free membership.

The above being correct, it would appear that the only supported way to get the 2012 HP working on 10.6 is having a 99USD developer program subscription. A workaround would be greatly appreciated, but I understand if there is a lack of interest / resources for 10.6. In this case, please just update the HP website with a note clarifying the situation. Thanks!

  Changed 2 years ago by applicative

I'm not sure if it adds anything, but I have this problem (I'm still using OSX 1.6). However if I build ghc-head locally then the ghci and runhaskell I get don't have the problem at all.

  Changed 22 months ago by MtnViewMark

  • status changed from new to closed
  • resolution set to fixed

I've updated language to make it clear that Xcode 4.1 or later is required for 64-bit on 10.6.

Note: See TracTickets for help on using tickets.