Stop! Tickets are now managed at GitHub.

Please enter new tickets, and find and edit existing tickets there:


Ticket #211 (closed defect: wontfix)

Opened 22 months ago

Last modified 15 months ago

Old version / uninstallation confusion

Reported by: mcandre Owned by: MtnViewMark
Priority: major Milestone:
Component: OSX installer Keywords: mac installer uninstall uninstaller
Cc:

Description

I downloaded the Haskell Platform 2012.2.0.0 32bit Mac installer and began running it.

It soon popped up with an error about previous versions being installed. The Wiki says to use the Uninstaller program: sudo /Library/Frameworks/GHC.framework/Versions/Current/Tools/Uninstaller.

http://www.haskell.org/haskellwiki/Mac_OS_X#Mac_OS_X_10.6_.28Snow_Leopard.29_and_10.7_.28Lion.29

Evidently this didn't remove much, because the Haskell Platform 2012 installer says I should use uninstall-hs instead.

I ran uninstall-hs thru MYLATESTVERSION, and that wasn't enough either. It said to run with the --remove option.

So I ran uninstall-hs thru MYLATESTVERSION --remove, and it raised about a thousand errors.

So I ran sudo uninstall-hs thru MYLATESTVERSION --remove, and at the end of the output, uninstall-hs says that traces of old Haskell files are STILL on my system. Ack!

Nevertheless, after that kerfuffle, running the Haskell Platform installer all over again appears to be fully operational. I just wish that this installer would run the proper commands for me, because there's a significant amount of hassle involved in cleaning the development environment.

Specs:

* Upgrading from Haskell Platform 2010 to Haskell Platform 2012 * Mac OS X 10.8.2 * MacBook? Pro 2009

Change History

Changed 22 months ago by MtnViewMark

Thank you for fixing the wiki page!

Could you be more precise about what you expected the installer to do? Did you want it offer to perform the sudo uninstall-hs for you?

Can you suggest a better wording for the message:

-- To actually remove these files, sudo run the command again with --remove -- To generate a script to remove these files, run the command again with --script

such that you would have realized you needed to run the --remove version with sudo the first time?

uninstall-hs is notable hesitant to do anything because it is really destructive.

Changed 15 months ago by MtnViewMark

  • status changed from new to closed
  • resolution set to wontfix

Without more info... closing.

Note: See TracTickets for help on using tickets.