Stop! Tickets are now managed at GitHub.

Please enter new tickets, and find and edit existing tickets there:


Ticket #24 (closed defect: wontfix)

Opened 6 years ago

Last modified 5 years ago

GHC in a directory with spaces causes configure failure

Reported by: larsv Owned by: refold
Priority: minor Milestone: 2009.2.0.1
Component: Windows installer Keywords:
Cc: the.dead.shall.rise@…

Description

I've attempted to build Gtk2Hs against the 2009.2.0 platform using the MinGW and MSYS versions recommended on the GHC wiki [2] with current autoconf/automake/libtool to be able to autoconf Gtk2Hs I run into an issue while configuring as the Platform installs into a folder with spaces (/c/Program Files (x86)/Haskell Platform/2009.2.0).

I'm unsure if the root cause is configure, Gtk2Hs or mingw, but it's most definitely due to there being spaces in the path. I assume there's a reason ghc usually installs to C:\ghc. This concern is lifted in ticket #6 by claus as well.

[1] -----8<----- checking for ghc... /c/Program Files (x86)/Haskell Platform/2009.2.0/ghc-6.10.2/bin/ghc ./configure: line 4749: test: too many arguments checking version of GHC... ./configure: line 4763: /c/Program: No such file or directory

configure: error: Gtj2Hs requires GHC 6.4 or later


[2] http://hackage.haskell.org/trac/ghc/wiki/Building/Preparation/Windows

Change History

Changed 6 years ago by refold

  • status changed from new to assigned

IMO, this is a bug in Gtk2Hs's configure, though we can certainly change the default install path (again!).

Changed 6 years ago by refold

  • cc the.dead.shall.rise@… added

Changed 6 years ago by refold

  • milestone set to 2009.2.1

Changed 5 years ago by refold

  • status changed from assigned to closed
  • resolution set to fixed

Fixed in the 2009.2.1 installer.

Changed 5 years ago by anonymous

  • status changed from closed to reopened
  • resolution fixed deleted

I think we should stick with the nice standard path. The ghc build system has already been fixed and the gtk2hs one can be too. It only affects a few people and it's still perfectly possible for them to choose a dir with no spaces.

Changed 5 years ago by refold

  • status changed from reopened to closed
  • resolution set to wontfix

OK, I've reverted this change.

Note: See TracTickets for help on using tickets.